CloudFlare Proxy Check Errors

Problem

You see the following CloudFlare® Proxy Check error at Configuration () > System Health:

WHMCS is running behind a CloudFlare proxy, but you have not configured proxy settings. This may cause login sessions to end prematurely. Click here to automatically reconfigure your CloudFlare proxy settings.

You may also see login sessions that end prematurely.

If you do not use CloudFlare but see frequent unexpected logouts, see Frequent Logouts.

Cause

WHMCS detected that you are using CloudFlare, but there is a misconfiguration in your settings for trusted proxies.

Solution

Click the link in the error message. The system will automatically correct the misconfiguration.

Last modified: 2025 April 8