Problem
You or your clients see errors or experience other problems while attempting to use Duo® Security for two-factor authentication (2FA).
You may see the following error in the Activity Log at Configuration () > System Logs:
Client Duo® Security Login Failed: invalid_client: Integration type does not support frameless access.
If you see the following error, see System Timezone Issues:
The second factor you supplied was incorrect. Please try again. You have 2 attempts remaining.
Cause
Duo ended support for the previous Duo Security iframe-based prompt on 2024-03-30. This error indicates that you need to upgrade your Duo credentials.
Solution
Our Duo Security integration uses Duo’s newer Duo Universal Prompt. To resolve Duo Security errors, you must activate Universal Prompt in your Duo Security account.
To resolve this error:
- Make at least one login attempt that uses Duo Security for 2FA.
- Log in to your Duo Security account.
- Click Applications in the left-side menu.
- Click on the application that you use with WHMCS.
- Find the Universal Prompt section.If your account is ready to activate Universal Prompt, you will see a Ready to activate message and a green checkmark icon next to Application Supports Universal Prompt.If you have not yet updated WHMCS or made at least one login attempt with Duo Security, you will see an Update required message. Make certain that you have successfully performed these steps.
- Under Activate Universal Prompt, select Show new Universal Prompt.
- Return to WHMCS and attempt authentication again.
Last modified: 2025 May 1