We log search terms to improve our documentation. For more information, read our Privacy Policy.


Smarty Policy Errors

Problem

Your WHMCS installation is not sending email or the sent email doesn’t display properly. When you check the log at Configuration () > System Logs, you see the following error:

Smarty Error: Not allowed by security policy

Cause

The email template contains advanced code that the default email security policy blocks.

Solution

To resolve this issue:

  1. Review the code in the email to confirm what it’s trying to send at Configuration () > System Settings > Email Templates.
  2. Add an exception to the email security policy to allow the desired code.

Last modified: 2025 July 28