Invalid Registration Period Errors

Problem

You see the following error when you place an order for a domain:

Invalid TLD/Registration Period Supplied for Domain Registration

Cause

This error occurs in the following situations:

  1. The domain extension (TLD) you selected is not configured.
  2. The registration period for the domain extension you selected is not configured.

Solution

Before you add a domain to an order, configure the domain extension and the desired registration period for the domain.

To do this, perform the following steps:

  1. Go to Configuration () > System Settings > Domain Pricing.
  2. Add the desired domain extension in the last row of extensions. Include the preceding . character.
  3. Click Save Changes.
  4. Click Pricing. A new window will appear.
  5. Click Enable for the desired registration period.
  6. Click Save Changes.

After you configure the domain extension and registration period, try to place an order for the domain again.

Last modified: 2025 October 9