Cloud ImportAssist Errors

Problem

You may see the following error while migrating data using ImportAssist:

Unable to connect to the database

Cause

WHMCS Cloud cannot reach the source MySQL® server, or the database is rejecting the connection. This commonly occurs when:

  • The source firewall blocks connections from the IP address range that your WHMCS Cloud region uses.
  • The source MySQL server does not accept remote connections.
  • The MySQL user only allows connections from localhost.
  • The source MySQL server requires connections over SSL or TLS.
  • The MySQL service is unreachable on port 3306.

Solution

To diagnose and fix the failure:

  1. Confirm that the source firewall permits inbound connections from the IP addresses (CIDR ranges) associated with your WHMCS Cloud service. To do this:
    1. Log in to your client account.
    2. Find your WHMCS Cloud region at Services > All Products/Services > Additional Information.
      Alternatively, resolve your service hostname using the ping or dig commands to obtain its IP address, then identify the matching region from the table below.
    3. Using your region, find the matching CIDR ranges in the table below.
    4. Add those CIDR ranges to your source firewall’s allow list.
  2. Confirm that the source MySQL server accepts remote connections. For example, check that the bind-address directive does not limit connections to 127.0.0.1.
  3. Confirm that the database user permits connections from a remote host. For example, the user’s host should not be localhost. If the user matches '<username>'@'localhost', WHMCS Cloud cannot access the database.
    After you change any user permissions, run FLUSH PRIVILEGES on the source MySQL server to apply those changes.
  4. Confirm that the source MySQL server does not require connections over SSL or TLS. Disable require_secure_transport for the duration of the import.
    ImportAssist does not support database connections over SSL/TLS.
  5. Test the credentials from a separate MySQL client on a remote host.
  6. Test reachability to MySQL port 3306 from a remote host using telnet or nc.

WHMCS Cloud Region IP Ranges

WHMCS Cloud points of presence use the following IP address (CIDR) ranges:

ZoneCIDR Range
AP Tokyo184.94.207.0/25
184.94.207.128/25
EU Zurich91.204.24.0/24
EU Dusseldorf184.94.201.0/24
USA Houston184.94.199.0/24
184.94.205.0/24
USA Dallas184.94.195.0/24
  • WHMCS Cloud services may share IP addresses between many customers. Your instance’s IP address may not be unique to you.
  • WHMCS may change the IP address of the service sometimes, but this change will be infrequent.
  • WHMCS may change CIDR ranges for WHMCS Cloud over time, including adding or removing CIDR ranges.

Last modified: 2026 June 9