Cloud ImportAssist Errors
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Problem
You may see the following error while migrating data using ImportAssist:
Unable to connect to the database
Cause
WHMCS Cloud cannot reach the source MySQL® server, or the database is rejecting the connection. This commonly occurs when:
- The source firewall blocks connections from the IP address range that your WHMCS Cloud region uses.
- The source MySQL server does not accept remote connections.
- The MySQL user only allows connections from
localhost. - The source MySQL server requires connections over SSL or TLS.
- The MySQL service is unreachable on port
3306.
Solution
To diagnose and fix the failure:
- Confirm that the source firewall permits inbound connections from the IP addresses (CIDR ranges) associated with your WHMCS Cloud service. To do this:
- Log in to your client account.
- Find your WHMCS Cloud region at Services > All Products/Services > Additional Information.Alternatively, resolve your service hostname using the
pingordigcommands to obtain its IP address, then identify the matching region from the table below. - Using your region, find the matching CIDR ranges in the table below.
- Add those CIDR ranges to your source firewall’s allow list.
- Confirm that the source MySQL server accepts remote connections. For example, check that the
bind-addressdirective does not limit connections to127.0.0.1. - Confirm that the database user permits connections from a remote host. For example, the user’s host should not be
localhost. If the user matches'<username>'@'localhost', WHMCS Cloud cannot access the database.After you change any user permissions, runFLUSH PRIVILEGESon the source MySQL server to apply those changes. - Confirm that the source MySQL server does not require connections over SSL or TLS. Disable
require_secure_transportfor the duration of the import.ImportAssist does not support database connections over SSL/TLS. - Test the credentials from a separate MySQL client on a remote host.
- Test reachability to MySQL port
3306from a remote host usingtelnetornc.
WHMCS Cloud Region IP Ranges
WHMCS Cloud points of presence use the following IP address (CIDR) ranges:
| Zone | CIDR Range |
|---|---|
| AP Tokyo | 184.94.207.0/25184.94.207.128/25 |
| EU Zurich | 91.204.24.0/24 |
| EU Dusseldorf | 184.94.201.0/24 |
| USA Houston | 184.94.199.0/24184.94.205.0/24 |
| USA Dallas | 184.94.195.0/24 |
- WHMCS Cloud services may share IP addresses between many customers. Your instance’s IP address may not be unique to you.
- WHMCS may change the IP address of the service sometimes, but this change will be infrequent.
- WHMCS may change CIDR ranges for WHMCS Cloud over time, including adding or removing CIDR ranges.
Last modified: 2026 June 9