Problem
You see one of the following errors while attempting to process payments with the WorldPay payment gateway module:
You have not configured a payment response password.
Your payment response password does not match.
Cause
Your WorldPay account configuration does not currently include the required Payment Response Password value, or the value in WHMCS does not match the value in your WorldPay account.
Solution
To resolve this error, add the Payment Response Password value that displays at Configuration () > System Settings > Payment Gateways to your WorldPay account.
If you have already set this value, check to ensure that it matches the value in the WorldPay control panel.
For steps, see WorldPay.
Last modified: 2026 January 20