Version 5.x System Requirements

From WHMCS Documentation

Most current web servers with PHP & MySQL installed will be capable of running WHMCS.

Minimum Requirements

Version 6.0 is the recommended version for all new installations and upgrades.
View System Requirements for 6.0 here

  • Linux or Windows OS
  • PHP Version 5.2
    • Curl Support (with SSL)
    • GD2 Image Library
    • JSON Enabled
    • PHP Memory Limit: 64 MB
  • MySQL Version 4.1.x and above
    • With MySQL Strict Mode disabled
  • Ioncube Loaders V4.0 or later

PHP 5.5 Compatibility
PHP 5.5 is not supported in WHMCS 5.3. WHMCS Version 6.0 supports both PHP 5.5 and 5.6.

If you would like any more information or need help in determining if your server meets these requirements, please contact us.