Difference between revisions of "System Requirements"

From WHMCS Documentation

m
 
Line 46: Line 46:
  
 
<div class="docs-alert-warning">
 
<div class="docs-alert-warning">
While these are the minimum requirements, we '''''strongly recommend using the latest available, stable releases of all software and extensions'''''.  Recommended suggestions are correct as at 26nd August 2017.
+
While these are the minimum requirements, we '''''strongly recommend using the latest available, stable releases of all software and extensions'''''.  Recommended suggestions are correct as at 26th August 2017.
 
</div>
 
</div>
  

Latest revision as of 07:31, 31 August 2017

Most current web servers* with PHP & MySQL installed will be capable of running WHMCS.

The following table shows the minimum and recommended system requirements for running WHMCS 7.0 and later.

Requirement Minimum Recommended
PHP Version 5.6.0 Latest 7.0.x Release
PHP Memory Limit 64MB 128MB**
PHP Database Extension PDO PDO
PHP Extensions Curl with SSL

GD2 Image Library
JSON Support
XML

Curl with SSL

GD2 Image Library
JSON Support
MBString
Iconv

MySQL Version 5.1.0 5.5.x
Ioncube Loaders 5.0.21 or later for PHP 5.6
6.0.2 or later for PHP 7
The latest 5.x version for PHP 5.6
The latest 6.x version for PHP 7

WHMCS 6.x supports PHP 5.3.7 or later, including PHP 5.4, 5.5 and 5.6.
WHMCS 7.x supports PHP 5.6 and 7.0

While these are the minimum requirements, we strongly recommend using the latest available, stable releases of all software and extensions. Recommended suggestions are correct as at 26th August 2017.

Looking for the requirements for the WHMCS 6.x series? Click here

* We validate WHMCS to run in Linux based environments running the Apache web server. Other environments such as Windows based configurations may experience compatibility issues and are not supported.

** Memory requirements vary depending upon the size and volume of activity in an installation. Your exact requirements may differ.

*** As part of PCI compliance, we recommend a SSL library capable of TLS 1.1 and/or 1.2. If using OpenSSL, version 1.0.1c or newer is recommended.