Admin Directory Errors
Problem
WHMCS displays one of the error messages below when it detects a conflict between your settings and the admin directory path that you are trying to access:
You are attempting to access the admin area via a directory that is not configured.
or
You are attempting to access the admin area via a directory that is different from the one configured.
or
You are attempting to access the admin area via a custom directory, but we have detected the presence of a default "admin" directory too.
or
The request path cannot be resolved.
Cause
These errors appear due to the following issues:
- You are attempting to access the wrong directory.
- The
$customadminpathline does not appear or is invalid in the WHMCSconfiguration.phpfile. - A recent update uploaded files to the default
admindirectory. As a result, the files in your custom admin directory may not be up-to-date.
Solution
There are multiple ways to resolve this issue, depending on the cause:
Check the Directory Path
Make certain that you are attempting to access the correct directory.
Update the configuration.php File
This troubleshooting information only applies to self-hosted WHMCS installations.
Update the configuration.php file with the correct path, and make certain to use it when accessing the Admin Area.
Make certain that this path does not conflict with a reserved system name, like
login. If it does, choose a different custom name.For more information, see The configuration.php File.
Verify Recent Update Files
This troubleshooting information only applies to self-hosted WHMCS installations.
If you have performed an update recently:
- Make certain that you uploaded all of the latest files to your custom admin directory.
- Delete the default
admindirectory and its contents.
For more information, see Rename the Admin Directory.
Revert the Admin Directory Name
This troubleshooting information only applies to self-hosted WHMCS installations.
If you continue to see the error message, revert your admin directory name to admin in order to regain access. Then, contact our support team for assistance.
Last modified: 2025 October 17