Blank or Partially-Rendered Pages

Problem

While using WHMCS, you encounter a blank or partially-rendered page.

If you encounter this issue while attempting to access the Admin Dashboard, see Blank Admin Dashboard.

Cause

This issue indicates that a fatal PHP error is occurring.

PHP errors can occur for many reasons. The most common causes are:

  • Missing or corrupted files or incomplete uploads.
  • The server doesn’t meet the minimum system requirements.
  • PHP, Apache®, or ionCube Loader®-related errors.
  • Incompatible hooks or addons.
  • Syntax errors in custom modules, hooks, or templates.

Troubleshooting

To troubleshoot this issue, enable error reporting. This should provide you with an error message to use to resolve the issue.

For more information and steps, see Enable Error Reporting.

Client Area Only

If the Admin Area is loading correctly and only the Client Area is blank, the template folder may be missing or the /templates_c folder may have an invalid path or may not be writeable.

Solution

To resolve this:

  1. Select the template again at Configuration () > System Settings > General Settings and click Save Changes.
  2. Ensure that the templates_c folder has the appropriate permissions and is writeable by the script (usually CHMOD 755, but some environments require CHMOD 777).
  3. If the /templates_c directory is in a custom location, ensure that the path is correct in the configuration.php file.
For help, contact your hosting provider or system administrator.

Admin Login Page Only

The admin login page does not use templates, so a blank page indicates a problem with the ionCube Loader® configuration on your server.

To find more troubleshooting information:

  1. Download the ionCube Loader Wizard.
  2. Upload it to the whmcs directory.
  3. Visit it in your browser.
For help, contact your hosting provider or system administrator.

If it reports that ionCube Loader is installed correctly, ensure that display_errors is enabled in the server’s PHP configuration. This can suppress WHMCS error messages with the display_errors line in the configuration.php file.

Problematic custom widgets may also cause a blank page. Try removing any non-standard files from the /modules/widgets directory.

Oops! or Blank Pages Elsewhere

If blank pages are occurring on all pages, try all of the above steps.

If the problem persists, review any custom files in the following locations and ensure there are no blank spaces or carriage returns outside the <?php and ?> tags:

/configuration.php
/includes/hooks/
/modules/admin/
/modules/addons/
/modules/registrars/
/modules/servers/
/modules/widgets/
/lang/
/lang/overrides/
/admin/lang/
/admin/lang/overrides/

It may be necessary to remove any custom files from these locations temporarily. If doing so resolves the issue, you can add them back one-by-one until the problem occurs, then contact the vendor of the offending file for a fix.

If none of the steps on this page fix the problem, contact our support team with a description of the troubleshooting you have done, reproduction instructions, and FTP/SFTP access.

Last modified: November 19, 2024