cURL Timeout Errors

Problem

You see one of the following errors:

Server Command Error - Curl Error - 28 connect() timed out
cURL error 28: Operation timed out
For more information about cURL errors, see libcurl Errors.

Cause

This error indicates that the operation timed out.

Servers and Provisioning

If you see this error while working with hosting servers and provisioning, it may indicate one of the following problems:

  • The server is too busy dealing with other requests.
  • The server required more than 150 seconds to provision the account.
  • The server’s site IP address does not match the server details in WHMCS.
  • The server doesn’t exist.

Updates

If you see this error while using the Automatic Updater feature at Utilities > Update WHMCS, the server was unable to download the .zip file containing the update files before it reached your server’s connection timeout limit. Several factors could cause this, including a slow network connection, network congestion, or a low connection timeout limit on the server.

If this occurs, the process will not change the WHMCS installation and will continue to operate on the original version.

The error message contains details about the point in the process at which the timeout occurred. For example:

...Operation timed out after 300000 milliseconds with 5917326 out of 84351336 bytes received...

  • 300000 milliseconds (5 minutes) is the maximum time that the server allocates for connections.
  • 5917326 bytes is the amount of data that the system downloaded within that time period.
  • 84351336 bytes is the total size of the new ZIP file.

Solution

Try again later. Network congestion may be temporary.

Servers and Provisioning

To resolve this issue for hosting servers:

  • Make certain that your firewalls are not blocking requests from WHMCS.
  • Make certain that you have correctly configured SSL mode for each of your servers at Configuration () > System Settings > Servers.

Updates

To resolve this issue for WHMCS updates, work with your hosting provider or system administrator to troubleshoot and resolve the network connectivity issues between your server and the WHMCS mirror at https://releases.whmcs.com/.

After you make the necessary server or network changes, you can start the update process again by going to Utilities > Update WHMCS and clicking Update Now. You can also choose to update WHMCS manually.

Last modified: February 4, 2025