Down for Maintenance Errors

Problem

You see a Down for Maintenance (Err2) error while attempting to use WHMCS.

For example:

Down for Maintenance (Err2) An upgrade is currently in progress... Please come back soon...

Cause

This error may be due to a mismatch between the database version and WHMCS version or PHP version.

During the Update Process

This message normally displays while the update process is in progress.

In many of these cases, a message may state that the database version does not match the file version:

WHMCS\Exception\Application\InstallationVersionMisMatch: Database version '8.6.2-release.1' does not match file version '8.7.1-release.1'

The system has successfully downloaded the WHMCS files or you have uploaded them, but the updates to the MySQL® database have not finished.

Solution

To resolve this issue:

  1. In your browser, go to the /install/install.php file in your WHMCS installation’s directory. For example, www.example.com/whmcs/install/install.php.
    If a 404 Page Not Found error displays, upload the /install directory and its contents to your server. You can download this as part of the Full Release files in our Members Area.
  2. Agree to the End User License Agreement.
  3. Click Continue.
  4. Back up the WHMCS MySQL database.
  5. Click I have a backup, start the upgrade. An Upgrade In Progress message will display while the upgrade process runs. Within a few minutes, a success message will display.
  6. Delete the install subdirectory from your server.
  7. Click the link to return to the Admin Area.
  8. Ensure that the version number in the Admin Dashboard sidebar or in Configuration () > System Health is the version you were updating to.

After an Update

If an update is not currently in progress, it indicates a version mismatch between the PHP files and the MySQL® database.

A mismatch may occur if:

  • Something terminated the automatic update process before it was complete.
  • You uploaded a new version of PHP files but have not yet performed the PHP update.
  • You applied a patch set to an incompatible version of the software.

Solution

To ensure that the update process is complete, use the browser method to apply the update.

For steps, see Update in the Browser.
If the page does not load or displays a 404 Page Not Found error, you will need to perform a manual update. For steps, see Update on the Command Line.

Last modified: October 30, 2024