Problem
The final column in your system’s log entries contains the server IP address instead of the admin’s or client’s IP address.
This may occur in any of the following logs at Utilities > System Logs:
- Activity Log
- Admin Log
- Whois Log
Cause
The IP address that the server configuration is supplying to PHP is incorrect.
WHMCS checks the following variables in descending order for an IP address. If the IP address is available and not a local address, it will use that as the client’s IP address on the order form, details, and logs. If none of these are available, WHMCS will return the REMOTE_ADDR as the IP address. This applies to both IPv4 and IPv6 connections.
HTTP\_CLIENT\_IP
HTTP\_X\_FORWARDED\_FOR
HTTP\_X\_FORWARDED
HTTP\_X\_CLUSTER\_CLIENT\_IP
HTTP\_FORWARDED\_FOR
HTTP\_FORWARDED
REMOTE\_ADDR
If one of these PHP variables is reporting the server’s IP address instead of the visitor’s IP address, WHMCS will record it.
This scenario often occurs on servers that use a proxy or forwarding service like CloudFlare®.
Solution
To resolve this issue, configure WHMCS to recognize the proxy server’s details:
- Go to Configuration () > System Settings > General Settings.
- Select the Security.
- Configure the Proxy IP Header and Trusted Proxies values per your proxy server’s configuration.
- Click Save Changes.
Last modified: October 30, 2024