Access Denied Forbidden Errors

Problem

While attempting authentication, you see the following error:

Oops! Access Denied - Forbidden

Access Denied - Forbidden errors.

Cause

If this error occurs while logging in as an admin, it indicates that the affected admin’s currently-assigned administrator role does not have the necessary permissions to perform the requested action. In this case, the error will list the required permissions.

If the error occurs when an admin clicks Login as Owner and does not list required permissions, it indicates that the user who is the account owner has not set a password.

Solution

Required Admin Permissions

To assign the necessary permissions:

  1. Go to Configuration () > System Settings > Administrator Roles.
  2. Edit the administrator role for the affected admin.
  3. Check the required permissions to enable them.
  4. Click Save Changes.

Missing Account Owner Password

Use one of the following methods to reset the account owner’s password:

Password Reset Email

To reset the user’s password using email:

  1. In the WHMCS Admin Area, go to the client’s profile’s Users tab.
  2. Find the user with the OWNER badge next to their name.
  3. Click Password Reset.
  4. Click OK.

The customer will receive an email that contains a reset link. They can click that link and follow the prompts to create a new password. After the customer has set a new password, the Login as Owner link in the client profile should function normally.

MySQL® Query

If you are able to run SQL commands on the command line, run the following query against the WHMCS MySQL database to specify a placeholder password:

UPDATE tblusers SET password = 'temppassword' WHERE id = x;

  • Replace temppassword with a random string.
  • Replace x with the relevant user ID. You can find the user ID at Clients > Manage Users.

After you run this command, the Login as Owner link in the client profile should function normally.

The customer will need to complete the password reset process via email before they will be able to log in.

Last modified: November 12, 2024