CloudFlare Proxy Check Errors

Problem

You see the following CloudFlare® Proxy Check error at Configuration () > System Health:

WHMCS may be operating behind a proxy or CDN, but you have not configured trusted proxy settings using CloudFlare IP addresses. This may cause login sessions to end prematurely. Apply settings now to correct this issue.

You may also see login sessions that end prematurely.

If you do not use CloudFlare but see frequent unexpected logouts, see Frequent Logouts.

Cause

WHMCS detected that you are using CloudFlare, but there is a misconfiguration in your settings for trusted proxies.

Solution

Click Apply settings now in the error message. The system will automatically correct the misconfiguration.

Last modified: June 14, 2024