Problem
When working with domains, you see an error that states that the registrant contact details are missing, incomplete, or invalid.
Cause
There is a problem with the contact details in one of the following locations in the client’s profile:
- The client’s details in the Profile tab.
- The contact details in the Contacts tab, if the client chose a registrant contact during checkout.
Solution
To resolve this issue, check and update the relevant contact details:
- Go to the Profile tab in the client’s profile.
- Make certain that all of the client’s details are present and valid. This includes First Name, Last Name, Email Address, Address 1, City, State/Region, Postcode, Country, and Phone Number.
- Click Save Changes.
- Go to the Contacts tab in the client’s profile.
- Make certain that the specified contact details are valid.
- Click Save Changes.
Last modified: November 4, 2024