Problem
When working with domains, you see an error that states that the registrant contact details are missing, incomplete, or invalid.
Cause
There is a problem in the client’s details in the Profile tab in the client’s profile.
Solution
To resolve this issue, update the client’s details:
- Go to the Profile tab in the client’s profile.
- Make certain that all of the client’s details are present and valid (First Name, Last Name, Email Address, Address 1, City, State/Region, Postcode, Country, and Phone Number).
- Click Save Changes.
Last modified: September 10, 2024