Problem
When attempting to register a domain, you may see an Automatic Domain Registration Suppressed
error in the Activity Log at Configuration () > System Logs.
These errors can have multiple causes depending on the exact message that you receive.
Cause
While attempting to register a domain, you see one of the following errors:
Error | Explanation |
---|---|
Automatic Domain Registration on Payment Suppressed for New Client | This error indicates that the domain is already registered or that you have enabled Only Auto Provision for Existing. If you enable Only Auto Provision for Existing, the system will not process domain registrations automatically. Instead, you must manually approve each domain order for registration. |
Automatic Domain Registration Suppressed as Domain Is Already Active | This error indicates that the domain is already registered or it may indicate that you have done something to overwrite WHMCS’s registration action for that domain. For example, you may have edited the domain record and changed the domain status from Pending to Active without actually registering it or accepted the order from Orders > Pending Orders. |
Solution
Manually approve the domain for registration.
For steps, see Manually Register a Domain.
Last modified: November 12, 2024