Microsoft Connection Failures

Problem

When configuring Microsoft® as your mail provider, a Connection unsuccessful error message displays after you click Connect:

Connection unsuccessful. Please close this window and try again.

Cause

The Application (client) ID and Client Secret combination for your Microsoft Entra® ID (formerly Microsoft Azure®) app are invalid.

Solution

Create a new app via the Microsoft Entra ID portal. Make certain to copy the Application (client) ID and Client Secret Value correctly.

Last modified: November 12, 2024