Undisclosed Recipients

Problem

Administrators may receive an email from the WHMCS system with two To email headers, one of which is to undisclosed-recipients:

    "To: undisclosed-recipients"
    "To: ".

Some email providers, notably Gmail™, may reject the email and bounce it back.

Cause

The email is addressed to the same admin email address in both the To and BCC fields. This occurs because the admin email address appears in the BCC Messages list in the Mail tab at Configuration () > System Settings > General Settings.

Solution

To fix this issue:

  1. Go to Configuration () > Manage Admins.
  2. Note all of your admins’ email addresses.
  3. Go to Configuration () > System Settings > General Settings and select the Mail tab.
    The Mail tab in General Settings
  4. Remove any of the admin email addresses from BCC Messages.
    The BCC Messages setting
  5. Click Save Changes.

Last modified: September 10, 2024