Duplicate Invoices (Same Dates)

Problem

The system automation tasks are generating two invoices for each client for the same services and due date. One invoice contains the expect line items, and the second invoice is empty.

You may also notice that clients receive two copies of payment overdue reminder emails.

If the invoices are for different dates, see Duplicate Invoices (Different Dates).

Cause

This issue may be due to the system cron running twice at the same time. The cron job should only run once per day, and should never run simultaneously.

Troubleshooting

To confirm this:

  1. Go to Configuration () > System Logs.
  2. Use the Search Filter tab to search for Cron Job: Starting Daily Automation Tasks and Cron Job: Completed Daily Automation Tasks.
  3. Check the Date column next to the entries.

If the logs list two or more of either of these log entries with the same timestamp, this confirms the issue.

Solution

If there is more than one entry per day, check the server’s cron job configuration to ensure there is only one entry for the cron.php file.

For more information, see System Cron and Check the Cron Job Status.

Last modified: June 14, 2024