Missing Service Invoices
Problem
You may encounter a problem in which the system does not generate an invoice.
Cause
This issue may be due to the service’s status or your invoice generation settings. If none of these are the problem, the issue may be due to a deleted invoice or an issue with the system cron’s daily run.
Troubleshooting
To troubleshoot this issue, check the service’s status and your invoice generation settings. If none of these are the problem, check for deleted invoices and verify whether the system cron is running successfully each day.
Service Status
To check whether the problem is due to the service’s status:
- Go to the Products/Services tab in the client profile and select the product that did not generate an invoice or send renewals.
- Find Status.
If you have enabled Continuous Invoice Generation, the system will not generate a renewal invoice unless Status is Active.
If Status is set to Active and there is no pending cancellation request, this setting is not the issue.
Solution
Select Active and save the change. The system will generate the renewal invoice the next time that the daily automation cron tasks run.
Cancellation Request
To check whether there is a pending cancellation request for the service:
- Go to the Products/Services tab in the client profile and select the product that did not generate an invoice or send renewals.
- Look for a Cancellation Request Notice message at the top of the tab:
The system will not generate an invoice for services that have a pending cancellation request.
Next Due Date Beyond Invoice Generation Days
To check whether the problem is due to your invoice generation settings:
- Go to Configuration () > System Settings > Automation Settings.
- Find Invoice Generation and note the current settings.
- Go to the Products/Services tab in the client profile and select the product that did not generate an invoice or send renewals.
- Find Next Due Date and compare it with the Invoice Generation settings. For example, if today is January 1st, Invoice Generation is
14
, and Next Due Date is January 15th, the invoice will generate tomorrow.- If the Next Due Date value is further in the future than the Invoice Generation value specifies, the system will not generate the invoice yet.
- If the Next Due Date value is within the number of days that the Invoice Generation value specifies, this is not the issue.
Solution
If the Next Due Date is too far in the future to have generated an invoice, you can generate the invoice early.
Previously Invoiced
The system will not automatically generate a new invoice if it has already generated an invoice for the current Next Due Date value and an admin deleted it.
Review the Log tab in the client’s profile for any Invoice Deleted
or Order Deleted
entries. This will identify who deleted the invoice and the time of deletion.
Solution
To resolve this issue and generate a new invoice:
- Go to the Products/Services tab in the client profile and select the product that did not generate an invoice or send renewals.
- Set the Next Due Date value to one day earlier.
- Click Save Changes.
The system will generate the renewal invoice the next time that the daily automation cron tasks run.
Daily Automation Cron Issue
The daily cron job handles invoice generation, payment reminders, and account suspensions and terminations according to your automation settings. If some of these do not occur, the cron job may not be running successfully.
Review Configuration () > System Logs and make sure that you see a number of entries beginning with Cron Job
each day. The final entry every day should be Cron Job: Completed
.
Last modified: November 19, 2024