Unexpected Next Due Date
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Problem
A service’s Next Due Date value may move to a date several months or years in the future. This results in missing invoices that the system does not generate.
Cause
Each time that the system marks an an invoice paid, the service Next Due Date value increments forward from the current value by one billing cycle.
If the system marks an invoice paid multiple times, the Next Due Date value will also increment forward multiple times, moving it further into the future.
For example:
- The system generates a new monthly invoice on January 1st.
- The system marks the invoice paid twice before the expected February 1st invoice.
- Because the system marked the January invoice paid twice, the Next Due Date moved two months ahead instead of one.
- The system does not generate a February invoice. Instead, the system generates the next invoice on March 1st.
This may occur if, for example, an admin marks a paid invoice as unpaid and the client pays it again.
Troubleshooting
To verify that this is the problem, look for corresponding entries in the client’s profile’s Log tab.
Solution
If you need a client to make a new payment for a paid invoice, use the Payment Reversals feature to reverse the previous payment. This will eliminate the risk of this issue happening again.
Last modified: November 12, 2024