Duplicate Invoice ID Errors

Problem

PayPal® is rejecting payment attempts with the following error:

DUPLICATE_INVOICE_ID

Cause

You are using the same PayPal account to process payments in multiple systems and have configured your PayPal account to block accidental payments.

Solution

Update your PayPal configuration to allow multiple payments per invoice ID.

To do this:

  1. Log in to your PayPal merchant account and go to your payment preferences.
  2. For Block accidental payments, select No, allow multiple payments per invoice ID.
  3. Save your changes.

Last modified: January 13, 2025