Duplicate Transactions

Problem

The system captures payment for an invoice multiple times in separate transactions.

You may also notice that the system has created duplicate invoices. If this has occurred, the system may have charged the client once for each duplicate invoice.

Cause

This issue may be due to the system cron running twice at the same time. The cron job should only run once per day, and should never run simultaneously.

Troubleshooting

To confirm this:

  1. Go to Configuration () > System Logs.
  2. Use the Search Filter tab to search for Cron Job: Starting Daily Automation Tasks and Cron Job: Completed Daily Automation Tasks.
  3. Check the Date column next to the entries.

If the logs list two or more of either of these log entries with the same timestamp, this confirms the issue.

Solution

If there is more than one entry per day, check the server’s cron job configuration to ensure there is only one entry for the cron.php file.

For more information, see System Cron and Check the Cron Job Status.

Last modified: November 12, 2024