Problem
You see one of the following errors while using the 2CheckOut or Skrill payment gateways:
MD5 Hash Failure
or
MD5 Signature Failure
Cause
The secret word in your payment gateway configuration at Configuration () > System Settings > Payment Gateways does not match the secret word in the 2CheckOut or Skrill control panel.
Solution
To resolve this issue:
- Log in to the 2CheckOut or Skrill control panel and verify the secret word.For 2CheckOut, make certain that the secret word contains only letters and numbers and does not contain any invisible trailing spaces.
- In the WHMCS Admin Area, Configuration () > System Settings > Payment Gateways.
- Update your payment gateway configuration to use the correct secret word.
- Click Save Changes.
Last modified: January 6, 2025