Missing PayPal Subscriptions

Problem

On WHMCS 8.7.2 or higher, you see the following error for a PayPal® transaction in the Activity Log at Configuration () > System Logs:

The system has detected a missing subscription. The subscription is not associated with any services, but the event was attributable to a client and/or invoice.

Cause

This message indicates that the subscription is not associated with any service, product addon, or domain in the WHMCS database for your installation. However, the system did find an alternate ID to use to identify an associated invoice or client.

Solution

If this message begins with [PAYMENT.SALE.COMPLETED], there is not an immediate issue, but you should review the subscription in order to understand why the ID is missing.

  • If the subscription is active, update the ID to associate the subscription with the relevant service. If you do not, the message will repeat for each payment.
  • If the subscription is cancelled, the cancellation event occurred before the final payment. You do not need to take further action.

Last modified: January 30, 2025