Problem
On WHMCS 8.7.2 or higher, you see the following error for a PayPal® transaction in the Activity Log at Configuration () > System Logs:
The system has detected an orphaned subscription. It is not associated with any services, nor was attributable to an invoice or client.
Cause
This message indicates that the subscription is not associated with any service, product addon, or domain in the WHMCS database for your installation. Additionally, the system could not find an alternate ID to use to identify an associated invoice or client.
Solution
If this message begins with [PAYMENT.SALE.COMPLETED]
and you updated to WHMCS 8.7.2 more than 48 hours ago, there is a serious problem. The PayPal account received payment, but WHMCS has not recorded it. Investigate the issue immediately to determine the necessary action.
If this message begins with [BILLING.SUBSCRIPTION.CREATED]
and you updated to WHMCS 8.7.2 within the last 48 hours, this is a normal indicator that a user checked out using PayPal just before you upgraded. You do not need to take further action.
Last modified: January 30, 2025