PayPal Payments Issues

Problem

In WHMCS 8.9 through 8.11 RC, after attempting to migrate to the new PayPal Payments payment gateway module from a previous PayPal® module, you are experiencing problems with subscriptions. PayPal is not processing any of the recurring payments that existed before you changed your payment gateway configuration.

In WHMCS 8.11 GA and later, WHMCS can automatically transition subscriptions from a deprecated PayPal module (PayPal Basic or PayPal Checkout to use vaulting with PayPal Payments. For more information, see Automated Transition from Deprecated PayPal Modules.

Cause

The new PayPal Payments payment gateway is our newest PayPal integration in WHMCS 8.9 and later, and we recommend it for all PayPal merchants. However, WHMCS 8.9 through 8.11 RC do not support migrating from another PayPal gateway to PayPal Payments if you process any recurring payments through PayPal. Instead, the system treats our previous PayPal payment gateways as separate entities and there is not currently a way to transfer subscriptions to another gateway. Because of this, when you deactivate the previous payment gateway, the system will stop all of its recurring payments.

If you want to start using PayPal Payments and only need to process one-time payments, you can safely activate PayPal Payments and then deactivate the previous PayPal module.

Solution

While you cannot transition existing subscriptions in WHMCS 8.9 through 8.11 RC, you can start using PayPal Payments for one-time payments and new recurring payments using vaulting. In this scenario, you hide but do not deactivate the previous module, which will continue to process existing subscriptions.

To do this:

  1. Activate and configure PayPal Payments.
    For more information, see Configure PayPal Payments.
  2. Find the previous PayPal gateway at Configuration () > System Settings > Payment Gateways.
  3. Uncheck Show on Order Form.
  4. Click Save Changes.

Last modified: October 30, 2024