PayFlow Pro Remote Storage Errors

Problem

You see the following error when attempting to create a credit card payment method via the Admin Area or Client Area using the PayFlow Pro or PayPal Pro Reference Payments payment gateway modules:

Details could not be saved. Remote storage failed

Cause

Due to restrictions in PayFlow’s Reference Payment features, PayFlow Pro and PayPal Pro Reference Payments do not support remote updating, storage, or deletion of card details.

Solution

Clients can specify a new card by viewing an invoice in the Client Area, clicking Pay Now, selecting a new credit card, and providing the card’s details.

Last modified: February 6, 2025