Problem
You see the following error while using the Stripe™ ACH payment gateway module:
Invalid Remote Token For Gateway
Cause
This error indicates that the client does not currently have a valid Stripe ACH pay method.
You cannot use local bank account pay methods to make a capture attempt. Instead, Stripe ACH requires storing the bank details in their system and then WHMCS stores a remote token for them.
Solution
To resolve this error:
- Go to the Summary tab of the client’s profile.
- Delete the local bank account pay method.
- Ask the customer to log in to the Client Area and pay the invoice by clicking Pay Invoice.
This will initiate the payment via Stripe ACH and create the necessary tokens for accepting future automated payments.
Last modified: 2025 March 12