No Stripe Customer Details Errors

Problem

You see the following error at Billing > Gateway Log while using the Stripe™ payment gateway module:

No Stripe Customer Details Found

Cause

The client does not have a payment method in WHMCS. You can confirm this in the Pay Methods section of the client’s profile’s Summary tab.

Solution

Ask the client to log in to the Client Area, go to the unpaid invoice, and click Pay Now to make a payment via Stripe. This will create a payment method to use for future automatic payments.

Last modified: 2025 March 25