Stripe Bad Request Errors

Problem

You or your customers see the following error in the Client Area while attempting to pay for an invoice or order using an existing stored payment method and the Stripe™ payment gateway module:

Bad Request

Cause

The customer or the token in WHMCS do not exist in Stripe.

Solution

To ensure that the pay method is correctly stored in Stripe, delete the stored payment method in the client’s profile’s Summary tab. Then, add the payment method again.

If this does not resolve the problem, your issue may be due to a system theme or order form template. For more information and additional troubleshooting steps, see Stripe Payment Method Errors.

Last modified: 2025 March 25