Stripe Payment Method Errors
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Problem
You see the following error at Billing > Gateway Log while using the Stripe™ payment gateway module:
An unexpected error - No Stripe Payment Method found from token
Cause
The system could not transmit some of the required data to Stripe. This may occur due to a problem in a system theme or order form template.
Troubleshooting
To check whether the problem is due to a customized or outdated system theme or order form template:
- Go to the General tab at Configuration () > System Settings > General Settings.
- Select Six or Twenty-One for System Theme.
- Go to the Ordering tab.
- Select a template for Default Order Form Template.
- Click Save Changes.
- Return to the Client Area and refresh the page. The error should resolve, indicating that the problem was in the previous system theme or order form template.
Solution
Make certain that your system theme and order form template customizations are up-to-date with your version of WHMCS.
You may also need to check for JavaScript errors in custom code (for example, templates, hooks, or addon modules) that are preventing the standard Stripe JavaScript from running correctly. Your browser console will show whether a JavaScript error is occurring.
- If one is, you must correct the custom JavaScript code.
- If the JavaScript error is in a third-party customization, contact the developer for assistance.
If the issue persists, contact our support team.
Last modified: 2025 March 25