Stripe Remote Transaction Failures

Problem

You see one of the following errors while using the Stripe™ payment gateway module:

Remote Transaction Failure. Please Contact Support
Error
Error Updating Remote Pay Method: Remote Storage Failed

Cause

These error messages can appear due to several different causes.

Troubleshooting

To determine the cause of this issue:

  1. Go to Billing > Gateway Log.
  2. Check the Result and Debug Data columns for error messages or codes from the time of the payment attempt.

You can also diagnose this error using your browser’s network analyzer tool.

For more information, see Stripe Try Again Errors.

Solution

To resolve most issues, perform the appropriate steps in Stripe’s Error Codes and Declines Codes documentation.

Payment Blocked By Stripe

A rule in your Stripe account blocked payment.

To resolve this issue:

  1. Log in to the Stripe Dashboard.
  2. Go to Developers > Logs.
  3. Find the log entries from the time at which the payment was attempted. The details of the log will show whether the payment failed (for example, with a The zip code you supplied failed validation error).
  4. Adjust the rules in your Stripe account for the error. For help, contact Stripe support.

No Stripe Details Found for Update or Customization Issues

There is interference from a third-party Stripe module. Using the official Stripe module requires the full uninstallation and removal of any custom or third-party Stripe integrations. This includes removal of all files and template modifications.

For example, the following issues may trigger this error:

  • A /includes/hooks/stripe.php hook file. Remove this file when switching to the WHMCS Stripe module.
  • Template customizations in your active order form template files.
  • The payment method uses a module other than Stripe. Perform one of the following actions:
    • Change the client’s Payment Method setting in the client’s Profile tab to the Stripe module.
    • Make Stripe the system default payment gateway at Configuration () > System Settings > Payment Gateways and choose All Payment Gateways.
Out-of-Date Template Files

The error indicates that you have out-of-date template files. Make certain that your client theme and order form templates are fully compatible with your version of WHMCS. The release notes for each version of WHMCS provide links to template changes.

Last modified: 2025 March 25