Unexpected PayPal Cancellation Emails

Problem

Your customers are receiving notification emails from PayPal® about a subscription cancellation after they make a payment.

Cause

In WHMCS 8.11 GA and later, after you activate PayPal Payments, if PayPal Basic or PayPal Checkout are also enabled, WHMCS transitions PayPal Basic and PayPal Checkout subscriptions to use vaulting with PayPal Payments. This transition occurs on a per-client basis the first time that each client pays you using PayPal.

Before transitioning a client’s subscriptions, the system will check to ensure that vaulting is available for the client’s PayPal account.

In order to transition these subscriptions, WHMCS must cancel the client’s PayPal Basic and PayPal Checkout subscriptions. This cancellation causes PayPal to send a subscription cancellation notification email to the client.

Solution

PayPal sends this email to your client automatically, and WHMCS cannot stop this from occurring during the subscription transition process. However, the email does not indicate a problem.

WHMCS will continue to process the client’s recurring payments normally through PayPal Payments and no further action is required.

Last modified: November 12, 2024