Unexpected Service Terminations
Problem
The system is unexpectedly terminating services (for example, hosting accounts).
Cause
The system may terminate services for the following reasons:
- The product’s configuration automatically terminates it after a fixed term. (The system will terminate it at the end of that term.)
- The service’s Next Due Date value is far enough in the past to trigger the Overdue Termination function.
- An admin clicked Terminate in the Module Commands section for the service.
All module actions, including termination, create an entry in the Activity Log at Configuration () > System Logs. Review the log entries at the time of termination to identify the cause.
Solution
Use the appropriate solution below:
Fixed Term
If the termination is due to the end of a fixed term, you will see the following log entry:
Cron Job: Auto Terminating Fixed Term Service - Service ID: x
...
Automated Task: Starting Fixed Term Terminations
To address this:
- Go to Configuration () > System Settings > Products/Services.
- Edit the desired product.
- In the Pricing tab, set Auto Terminate/Fixed Term to
0
. - Click Save Changes.
Repeat this process for any other products that you do not want to automatically terminate after a fixed term.
Overdue Termination
If the termination is because the service is overdue, you will see the following log entry:
Cron Job: Terminating Service - Service ID: x
...
Automated Task: Starting Overdue Terminations
To address this:
- Go to Configuration () > System Settings > Automation Settings.
- Increase the Termination Days value.
- Click Save Changes.
This will increase the amount of time before the system terminates overdue services.
Admin Termination
If the termination is because an admin terminated the service, you will see the following log entry:
Module Terminate Successful - Service ID: x
This entry indicates that an admin clicked Terminate under the Module Commands section in the Products/Services tab of the client’s profile.
You can review the User column for the log entry to determine which admin performed the action.
Last modified: November 12, 2024