Problem
While provisioning an account on a cPanel & WHM server using the cPanel module, you see the following error:
Access Denied/Permission Denied
Cause
An Access Denied
error indicates that the cPanel & WHM server denied WHMCS access to perform the requested action (for example, creating an account).
Solution
To resolve this issue:
- Go to Configuration () > System Settings > Servers.
- Check whether the server settings, including the username and API token, are valid.
- Check whether the API credentials for the server have the required permissions to perform the action.
- Go to the client’s profile and choose the Products/Services tab.
- Check to ensure that the Username and Server values match the account records in cPanel & WHM.
- Check whether the user has the required permissions to manage the cPanel hosting account.
- Click Test Connection to confirm that the account has access.
Last modified: November 12, 2024