Argument 7 Ticket Errors

Problem

After performing a WHMCS software update, emails that the system imported to the support ticket system bounce back to the sender with the following error:

Argument 7 passed to processPoppedTicket() must be an instance of WHMCS\Mail\AutoSubmittedHeader, array given, called in /path/to/crons/pop.php on line 0

For more information about email importing and the pop.php file, see Email Importing.

Cause

This issue is due to the presence of a pop.php file from an older version of WHMCS.

This may occur if you have customized the location of the crons directory and:

  • The $crons_dir value is missing from the configuration.php file. As a result, the automatic updater did not update the crons folder.
  • During a manual update, the new crons directory contents did not copy to the custom location.

Solution

To resolve this issue:

  1. Download the full release files or contact your license reseller to ask for them.
  2. Upload a new set of files from the crons directory to the custom location on your server, overwriting the existing files.
  3. Make certain that you have completed all of our recommended steps for crons directory customization.
    For more information, see Move the Cron Directory.

Last modified: November 12, 2024