POP3 Cron Not Running

Problem

You experience problems with importing email ticket replies. Full Administrators may receive a warning email indicating that POP3 details exist for a support department but the required cron job is not configured to import the emails. You may also see the following error:

WHMCS Pop Cron Did Not Run

Cause

You may receive this email if you have configured POP3 details for a support department but the cron job does not run successfully. This may indicate that you have not configured the required cron job, or it may not be able to finish importing emails.

Troubleshooting

To troubleshoot this issue, ensure that the cron job is configured. If that is not the issue, you will need to ensure that the cron job can finish successfully.

Check for Cron Job Configuration

To complete cron configuration:

  1. Go to Configuration () > System Settings > Support Departments.
    Support departments in the Admin Area.
  2. Copy the cron job command for pop.php at the top of the page.
    Editing a support department in the Admin Area.
  3. Log in to your server and create a new cron job to execute the pop.php script every five minutes.
For more information, see Email Piping.

Ensure Completion

If a cron job for the pop.php script is already configured, the email indicates that an error is preventing the script from completing. Check the Ticket Mail Import Log at Configuration () > System Logs for more information about the error and to determine next steps.

You can also find error details by temporarily adding the following line to the configuration.php file and then visiting http://www.example.com/crons/pop.php, where www.example.com is your WHMCS installation’s location:

$pop_cron_debug = true;
For more information about updating the configuration.php file, see The configuration.php File.

Workaround

You can also resolve this error by disabling email importing.

To do this:

  1. Configuration () > System Settings > Support Departments.
    Support departments in the Admin Area.
  2. Edit a department.
    Editing a support department in the Admin Area.
  3. Clear the POP3 Importing Configuration settings.
  4. Click Save Changes.
  5. Repeat the process for each support department.

WHMCS will no longer attempt to import emails from the inbox.

Last modified: October 30, 2024