Update Message Validation Errors

Problem

While trying to update WHMCS at Utilities > Update WHMCS, you see the following error:

Update Message Validation Issue This update contains notification messages that WHMCS could not validate.

Cause

The Automatic Updater feature at Utilities > Update WHMCS can display important messages before initiating the update process. A digital cryptographic signature protects them. This message indicates that the cryptographic validation is failing.

There are several potential causes of this issue:

  • The CA bundles are out of date and the system cannot validate the certificate.
  • OpenSSL is out of date.
  • A PHP configuration is causing the cryptographic validation to fail.
  • Your server is the target of a Man-in-the-Middle (MITM) attack.

Solution

To resolve this issue:

  1. Go to Utilities > Update WHMCS and click Check for Updates. This will cause WHMCS to reevaluate the available updates and may complete the cryptographic validation.
  2. Ensure that OpenSSL is up-to-date on your server.
    For help, contact your system administrator or hosting provider.
  3. Go to Utilities > Update WHMCS and click Check for Updates again.
  4. Ensure that the root CA bundles on your server are up-to-date.
    For more information on updating root CA bundles, see Outdated root CA Bundles.
  5. Go to Utilities > Update WHMCS and click Check for Updates again.
If the problem persists after performing these steps, contact WHMCS Technical Support.

Last modified: May 29, 2024